当前位置:网站首页>SDUT 2877:angry_birds_again_and_again

SDUT 2877:angry_birds_again_and_again

2022-08-11 08:35:00 51CTO


angry_birds_again_and_again

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^


题目描述


The problems called "Angry Birds" and "Angry Birds Again and Again" has been solved by many teams in the series of contest in 2011 Multi-University Training Contest.


This time we focus on the yellow bird called Chuck. Chuck can pick up speed and distance when tapped.


You can assume that before tapped, Chuck flies along the parabola. When tapped, it changes to fly along the tangent line. The Chuck starts at the coordinates (0, 0). Now you are given the coordinates of the pig (Px, 0), the x-coordinate of the tapping position (Tx) and the initial flying angle of Chuck (α).

SDUT 2877:angry_birds_again_and_again_程序设计竞赛

∠AOx = α

Please calculate the area surrounded by Chuck’s path and the ground.(The area surrounded by the solid line O-Tapping position-Pig-O)


输入


The first line contains only one integer T (T is about 1000) indicates the number of test cases. For each case there are two integers, px tx, and a float number α.(0 < Tx ≤ Px ≤ 1000, 0 < α <  

SDUT 2877:angry_birds_again_and_again_#include_02

) .

输出

One line for each case specifying the distance rounded to three digits.


示例输入

      
      
12 1 1.0
  • 1.

示例输出

      
      
0.692
  • 1.

提示


来源


2014年山东省第五届ACM大学生程序设计竞赛

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

题意:给出两个函数,定积分求区域面积。


      
      
#include <stdio.h>
#include <math.h>
int main()
{
int T;
double c, t, p;
scanf( "%d", & T);
while( T --)
{
scanf( "%lf%lf%lf", & p, & t, & c);
double b = tan( c);
double a = b * p /( 2 * t * t - 2 * p * t - t * t);
double area =( 1 / 3.0) * a * t * t * t + 0.5 * b * t * t +( p - t) *( a * t * t + b * t) * 0.5;
printf( "%.3lf\n", area);
}
return 0;
}
  • 1.
  • 2.
  • 3.
  • 4.
  • 5.
  • 6.
  • 7.
  • 8.
  • 9.
  • 10.
  • 11.
  • 12.
  • 13.
  • 14.
  • 15.
  • 16.
  • 17.


原网站

版权声明
本文为[51CTO]所创,转载请带上原文链接,感谢
https://blog.51cto.com/u_15746719/5565563